aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkeduvocdocument/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkeduvocdocument/APKBUILD')
-rw-r--r--community/libkeduvocdocument/APKBUILD32
1 files changed, 21 insertions, 11 deletions
diff --git a/community/libkeduvocdocument/APKBUILD b/community/libkeduvocdocument/APKBUILD
index a8c05fdf506..73c404f5c53 100644
--- a/community/libkeduvocdocument/APKBUILD
+++ b/community/libkeduvocdocument/APKBUILD
@@ -1,34 +1,44 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkeduvocdocument
-pkgver=21.04.2
+pkgver=24.02.2
pkgrel=0
-# s390x, mips64 blocked by kio-dev
-arch="all !armhf !s390x !mips64"
+arch="all !armhf"
url="https://edu.kde.org"
pkgdesc="Library to parse, convert, and manipulate KVTML files"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev ki18n-dev karchive-dev kio-dev"
+makedepends="
+ extra-cmake-modules
+ karchive-dev
+ ki18n-dev
+ kio-dev
+ qt6-qtbase-dev
+ samurai
+ "
+_repo_url="https://invent.kde.org/education/libkeduvocdocument.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/libkeduvocdocument-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-bb6738a88fd105c013e799b8e9501a10d0f1963a39153b7e2b8975bb9d29e6d1a3153689df84967c8ab283c9ecdf370c0d341da949f843fa28e0578c851f0a14 libkeduvocdocument-21.04.2.tar.xz
+b0851f80c9e1c1bd857a40811416c1823a7b6f68794ff4775ff9194082e7e569d79ccd30b38595672c80a9dcc9d29c9bc9358febe7d49e434d5e049323a6e4a3 libkeduvocdocument-24.02.2.tar.xz
"