aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkeyfinder/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkeyfinder/APKBUILD')
-rw-r--r--community/libkeyfinder/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/libkeyfinder/APKBUILD b/community/libkeyfinder/APKBUILD
index 4c6bec279f4..ad42f2622f3 100644
--- a/community/libkeyfinder/APKBUILD
+++ b/community/libkeyfinder/APKBUILD
@@ -1,22 +1,23 @@
# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=libkeyfinder
-pkgver=2.2.5
+pkgver=2.2.8
pkgrel=0
pkgdesc="Musical key detection for digital audio"
url="https://mixxxdj.github.io/libkeyfinder/"
arch="all"
license="GPL-3.0-or-later"
makedepends="
- catch2
+ catch2-3
cmake
fftw-dev
+ samurai
"
subpackages="$pkgname-dev"
-source="https://github.com/mixxxdj/libkeyfinder/archive/v$pkgver/libkeyfinder-v$pkgver.tar.gz"
+source="https://github.com/mixxxdj/libkeyfinder/archive/$pkgver/libkeyfinder-$pkgver.tar.gz"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -33,5 +34,5 @@ package() {
}
sha512sums="
-54463d1f1111dc474d3e43723fddd5579ea1a3842f99f43e50e85622a1d6ee6fe42b22c300ce5ba5807cf6b2d7067af741773af95974a42c5d863c53165893eb libkeyfinder-v2.2.5.tar.gz
+31d86715172b62dd72b122a8d480db4598731b87ca58522ad797116acfcbc53b8ecf8fe7eb2b129857b5044b27d32dda9e03927e0a27f8edcdc5d6ce607a76eb libkeyfinder-2.2.8.tar.gz
"