aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkeyfinder/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkeyfinder/APKBUILD')
-rw-r--r--community/libkeyfinder/APKBUILD47
1 files changed, 23 insertions, 24 deletions
diff --git a/community/libkeyfinder/APKBUILD b/community/libkeyfinder/APKBUILD
index 64411af069a..ad42f2622f3 100644
--- a/community/libkeyfinder/APKBUILD
+++ b/community/libkeyfinder/APKBUILD
@@ -1,39 +1,38 @@
# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=libkeyfinder
-pkgver=2.2.2
+pkgver=2.2.8
pkgrel=0
pkgdesc="Musical key detection for digital audio"
-url="http://www.ibrahimshaath.co.uk/keyfinder/"
+url="https://mixxxdj.github.io/libkeyfinder/"
arch="all"
license="GPL-3.0-or-later"
-# Its just using qmake
-makedepends="qt5-qtbase-dev fftw-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="libkeyfinder-$pkgver.tar.gz::https://github.com/ibsh/libKeyFinder/archive/v$pkgver.tar.gz
- alpine-settings-to-pro.patch
- add-missing-include-for-ppc64le.patch"
-builddir="$srcdir/libKeyFinder-$pkgver"
+makedepends="
+ catch2-3
+ cmake
+ fftw-dev
+ samurai
+ "
+subpackages="$pkgname-dev"
+source="https://github.com/mixxxdj/libkeyfinder/archive/$pkgver/libkeyfinder-$pkgver.tar.gz"
build() {
- qmake-qt5 PREFIX=/usr
- make
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
}
-package() {
- make INSTALL_ROOT="$pkgdir" install
- install -Dm644 "$builddir"/README.md \
- "$pkgdir"/usr/share/doc/$pkgname/README.md
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
-check() {
- cd "$builddir/tests"
- ln -s "$builddir" keyfinder
- qmake-qt5
- make
- LD_LIBRARY_PATH="$builddir" ./tests
+package() {
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="69981e94928ada5a51649cf7cf11fa91aa09480907355a364c491a42597922804b0d65744ef021e781807cfd1c7bdb5c8e152fdeda7120a93631d4e2573b6388 libkeyfinder-2.2.2.tar.gz
-580c968da0d24126d92b09cc4a970bb898fe020f2b9a9232d80ef63be8d3f90e618ea0b2f66ccde174a51dcf7160dfd62ab3b9428bf0ae6b11608b7dd7aede23 alpine-settings-to-pro.patch
-6292619361970bb85bb41a9ea94f12b2d70ca2b6d1957d9e27c56dbc3eaf55c49eb3616c0cbcd9b5855197f66c67064a8461c693e90a037e1019f0cd5da90587 add-missing-include-for-ppc64le.patch"
+sha512sums="
+31d86715172b62dd72b122a8d480db4598731b87ca58522ad797116acfcbc53b8ecf8fe7eb2b129857b5044b27d32dda9e03927e0a27f8edcdc5d6ce607a76eb libkeyfinder-2.2.8.tar.gz
+"