aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkgapi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkgapi/APKBUILD')
-rw-r--r--community/libkgapi/APKBUILD79
1 files changed, 79 insertions, 0 deletions
diff --git a/community/libkgapi/APKBUILD b/community/libkgapi/APKBUILD
new file mode 100644
index 00000000000..e60c754f8fc
--- /dev/null
+++ b/community/libkgapi/APKBUILD
@@ -0,0 +1,79 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
+pkgname=libkgapi
+pkgver=24.02.1
+pkgrel=0
+pkgdesc="LibKGAPI is a KDE-based library for accessing various Google services via their public API"
+# armhf blocked by extra-cmake-modules
+# ppc64le, s390x, riscv64 and armv7 blocked by qt6-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
+url="https://community.kde.org/KDE_PIM"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+depends_dev="
+ cyrus-sasl-dev
+ kcalendarcore-dev
+ kcontacts-dev
+ kio-dev
+ kwallet-dev
+ kwindowsystem-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
+checkdepends="xvfb-run"
+subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/libkgapi.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkgapi-$pkgver.tar.xz"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
+}
+
+check() {
+ # calendar-freebusyqueryjobtest, contacts-contactfetchjobtest,
+ # contacts-contactcreatejobtest and contacts-contactmodifyjobtest are broken
+ # tasks-taskfetchjobtest fails on the builders
+ # contacts-contactfetchjobtest: https://gitlab.alpinelinux.org/alpine/aports/-/issues/11787
+ # calendar-event-*: UTC+02 != UTC+02:00
+ local skipped_tests="("
+ local tests="
+ tasks-taskfetchjob
+ calendar-freebusyqueryjob
+ contacts-contactfetchjob
+ contacts-contactcreatejob
+ contacts-contactmodifyjob
+ calendar-eventcreatejob
+ calendar-eventmodifyjob
+ calendar-eventfetchjob
+ "
+ case "$CARCH" in
+ x86) tests="$tests
+ calendar-calendardeletejob
+ calendar-eventdeletejob
+ " ;;
+ esac
+ for test in $tests; do
+ skipped_tests="$skipped_tests|$test"
+ done
+ skipped_tests="$skipped_tests)test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+cfa23bed5819482ed337b528a76a854f3f7c2785844757fba7a38a1f904b4ee8dd469309fe79f038ab620ed593615892deb0dad730ea10b768791396022315a8 libkgapi-24.02.1.tar.xz
+"