aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkgapi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkgapi/APKBUILD')
-rw-r--r--community/libkgapi/APKBUILD56
1 files changed, 40 insertions, 16 deletions
diff --git a/community/libkgapi/APKBUILD b/community/libkgapi/APKBUILD
index f6a081fd075..3c2f6c39e80 100644
--- a/community/libkgapi/APKBUILD
+++ b/community/libkgapi/APKBUILD
@@ -1,12 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkgapi
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
pkgdesc="LibKGAPI is a KDE-based library for accessing various Google services via their public API"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x, riscv64 and armv7 blocked by qt6-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
@@ -16,40 +19,61 @@ depends_dev="
kio-dev
kwallet-dev
kwindowsystem-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
"
makedepends="$depends_dev
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libkgapi-$pkgver.tar.xz
- 0001-fix-build.patch
- "
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/libkgapi.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkgapi-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
# calendar-freebusyqueryjobtest, contacts-contactfetchjobtest,
# contacts-contactcreatejobtest and contacts-contactmodifyjobtest are broken
# tasks-taskfetchjobtest fails on the builders
# contacts-contactfetchjobtest: https://gitlab.alpinelinux.org/alpine/aports/-/issues/11787
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(tasks-taskfetchjob|calendar-freebusyqueryjob|contacts-contact(fetchjob|createjob|modifyjob))test"
+ # calendar-event-*: UTC+02 != UTC+02:00
+ local skipped_tests="("
+ local tests="
+ tasks-taskfetchjob
+ calendar-freebusyqueryjob
+ contacts-contactfetchjob
+ contacts-contactcreatejob
+ contacts-contactmodifyjob
+ calendar-eventcreatejob
+ calendar-eventmodifyjob
+ calendar-eventfetchjob
+ "
+ case "$CARCH" in
+ x86) tests="$tests
+ calendar-calendardeletejob
+ calendar-eventdeletejob
+ " ;;
+ esac
+ for test in $tests; do
+ skipped_tests="$skipped_tests|$test"
+ done
+ skipped_tests="$skipped_tests)test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-f14c0b97cc2e92a64aee41547347d67fe3c44baceff97eea83ea4cbb4ddd8a979081d4c8e61c099f327184e863b159e6c65c07beca25cbd9c11ba6d4d1d92b98 libkgapi-21.12.1.tar.xz
-48ba9a974b10be0fe204a50ec15d7e48f17fa3d3211ad9a22ad0ca5742fd6121ed81563f59c57b6d618597c74e6b831dbc5f046baf64e41a4315663e09c5b74f 0001-fix-build.patch
+6c50b109414b7f31bd4c051bda94440416114320fcd2f3f4cfd9bf2255ce31ed328fd986d1c21cd481e9f4e7dd63b13c5a1bced80c7f7b45972a8ab8f46ad783 libkgapi-24.02.2.tar.xz
"