aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkgapi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkgapi/APKBUILD')
-rw-r--r--community/libkgapi/APKBUILD49
1 files changed, 35 insertions, 14 deletions
diff --git a/community/libkgapi/APKBUILD b/community/libkgapi/APKBUILD
index ee4f818551c..e60c754f8fc 100644
--- a/community/libkgapi/APKBUILD
+++ b/community/libkgapi/APKBUILD
@@ -1,12 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkgapi
-pkgver=22.04.1
+pkgver=24.02.1
pkgrel=0
pkgdesc="LibKGAPI is a KDE-based library for accessing various Google services via their public API"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !riscv64"
+# ppc64le, s390x, riscv64 and armv7 blocked by qt6-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
@@ -16,19 +19,18 @@ depends_dev="
kio-dev
kwallet-dev
kwindowsystem-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
"
makedepends="$depends_dev
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libkgapi-$pkgver.tar.xz
- 0001-fix-build.patch
- "
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/libkgapi.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkgapi-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -39,13 +41,33 @@ build() {
}
check() {
- cd build
# calendar-freebusyqueryjobtest, contacts-contactfetchjobtest,
# contacts-contactcreatejobtest and contacts-contactmodifyjobtest are broken
# tasks-taskfetchjobtest fails on the builders
# contacts-contactfetchjobtest: https://gitlab.alpinelinux.org/alpine/aports/-/issues/11787
# calendar-event-*: UTC+02 != UTC+02:00
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(tasks-taskfetchjob|calendar-freebusyqueryjob|contacts-contact(fetchjob|createjob|modifyjob)|calendar-event(createjob|modifyjob|fetchjob))test"
+ local skipped_tests="("
+ local tests="
+ tasks-taskfetchjob
+ calendar-freebusyqueryjob
+ contacts-contactfetchjob
+ contacts-contactcreatejob
+ contacts-contactmodifyjob
+ calendar-eventcreatejob
+ calendar-eventmodifyjob
+ calendar-eventfetchjob
+ "
+ case "$CARCH" in
+ x86) tests="$tests
+ calendar-calendardeletejob
+ calendar-eventdeletejob
+ " ;;
+ esac
+ for test in $tests; do
+ skipped_tests="$skipped_tests|$test"
+ done
+ skipped_tests="$skipped_tests)test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
@@ -53,6 +75,5 @@ package() {
}
sha512sums="
-ff4f7f8116fd7ccdf15e5bb45167434e3100d59dd094d17bd6dbc4fd909061740f651fd1be7114ce79e6c663a9f3e46ae42dff01baaaaba1f4cc25a20da1a20d libkgapi-22.04.1.tar.xz
-48ba9a974b10be0fe204a50ec15d7e48f17fa3d3211ad9a22ad0ca5742fd6121ed81563f59c57b6d618597c74e6b831dbc5f046baf64e41a4315663e09c5b74f 0001-fix-build.patch
+cfa23bed5819482ed337b528a76a854f3f7c2785844757fba7a38a1f904b4ee8dd469309fe79f038ab620ed593615892deb0dad730ea10b768791396022315a8 libkgapi-24.02.1.tar.xz
"