aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkmahjongg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkmahjongg/APKBUILD')
-rw-r--r--community/libkmahjongg/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/libkmahjongg/APKBUILD b/community/libkmahjongg/APKBUILD
index c7d34c9e178..d5a9661557f 100644
--- a/community/libkmahjongg/APKBUILD
+++ b/community/libkmahjongg/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkmahjongg
-pkgver=21.08.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked polkit -> kconfigwidgets
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games"
pkgdesc="Common code, backgrounds and tile sets for games using Mahjongg tiles"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -17,24 +19,24 @@ makedepends="
kcoreaddons-dev
ki18n-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libkmahjongg-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
-options="!check" # No tests found
+_repo_url="https://invent.kde.org/games/libkmahjongg.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkmahjongg-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -42,5 +44,5 @@ package() {
}
sha512sums="
-5c4bb4be056799a70baf9c2e01166d0703ca7e917d013ffebda31c9031c944d358966fe450ddf4c70eeb93fc60297167405ddd84c06228aba307e1b2900e4ec0 libkmahjongg-21.08.2.tar.xz
+7b15e25f5c7f552334cacb645d07603836485de8d954b6f7db159ebbb2f61612f3375b6b7656453a01629635b91c061d045227ce2e39e3eaa1932446d73c031b libkmahjongg-24.02.1.tar.xz
"