aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkomparediff2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkomparediff2/APKBUILD')
-rw-r--r--community/libkomparediff2/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/libkomparediff2/APKBUILD b/community/libkomparediff2/APKBUILD
index b2b1134b09c..b51617d81c4 100644
--- a/community/libkomparediff2/APKBUILD
+++ b/community/libkomparediff2/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkomparediff2
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/development"
pkgdesc="Library to compare files and strings"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
@@ -17,22 +19,24 @@ makedepends="
ki18n-dev
kio-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libkomparediff2-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/sdk/libkomparediff2.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkomparediff2-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -40,5 +44,5 @@ package() {
}
sha512sums="
-02f02c7de6f00204de3db9090e252e56bbfb22940b7d28d148e06624f4411a874adff87ed718f003eed05eede73f2c03886d14ffe03c5f3a7846b96d22352907 libkomparediff2-21.08.3.tar.xz
+f5e616687a792b43aaf70269bfd3696dc07a1d3e76c52b58adb1601e2e51ae3b3e4c6bc7b510e5cfdadb060729abfe1357e66c7a99294f48badaeca454c8b7aa libkomparediff2-24.02.2.tar.xz
"