aboutsummaryrefslogtreecommitdiffstats
path: root/community/libksane/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libksane/APKBUILD')
-rw-r--r--community/libksane/APKBUILD40
1 files changed, 29 insertions, 11 deletions
diff --git a/community/libksane/APKBUILD b/community/libksane/APKBUILD
index 5bcecdbca76..e5fd04b1c50 100644
--- a/community/libksane/APKBUILD
+++ b/community/libksane/APKBUILD
@@ -1,31 +1,49 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libksane
-pkgver=20.04.1
+pkgver=24.02.2
pkgrel=0
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://www.kde.org/applications/graphics/"
pkgdesc="An image scanning library"
license="LGPL-2.1-only OR LGPL-3.0-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev ki18n-dev kwidgetsaddons-dev ktextwidgets-dev kwallet-dev sane-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libksane-$pkgver.tar.xz"
+depends_dev="
+ ki18n-dev
+ ksanecore-dev
+ ktextwidgets-dev
+ kwallet-dev
+ kwidgetsaddons-dev
+ qt6-qtbase-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/graphics/libksane.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libksane-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="b40a7ffd107e6f07b00ab98240f065f12b0dc8b557c94f09203eef6979ac4fc3e17d0f98ca7653a9740e44676a87793a68c4564941265666957103313cd6773b libksane-20.04.1.tar.xz"
+sha512sums="
+e5ad9152760384be4f1aa2b7cf54161caceb3fa68e9745606398cadd6e2e44c9b4b0d7d4cbf51c44667697221d6c7ab8ee3dcb9e210bd341d33bd7cee006909a libksane-24.02.2.tar.xz
+"