aboutsummaryrefslogtreecommitdiffstats
path: root/community/libksieve/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libksieve/APKBUILD')
-rw-r--r--community/libksieve/APKBUILD35
1 files changed, 21 insertions, 14 deletions
diff --git a/community/libksieve/APKBUILD b/community/libksieve/APKBUILD
index 28999bb4d9e..4eeea057112 100644
--- a/community/libksieve/APKBUILD
+++ b/community/libksieve/APKBUILD
@@ -1,12 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libksieve
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
pkgdesc="KDE PIM library for managing sieves"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
license="GPL-2.0-only"
depends_dev="
@@ -24,35 +27,39 @@ depends_dev="
kwindowsystem-dev
libkdepim-dev
pimcommon-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
syntax-highlighting-dev
"
makedepends="$depends_dev
+ doxygen
extra-cmake-modules
+ graphviz
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libksieve-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/libksieve.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libksieve-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
check() {
- cd build
-
# libksieveui-findbar-findbarbasetest, sieveeditorhelphtmlwidgettest and sieveeditor-autocreatescripts-sieveeditorgraphicalmodewidgettest require OpenGL
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(libksieveui-findbar-findbarbase|sieveeditorhelphtmlwidget|sieveeditor-autocreatescripts-sieveeditorgraphicalmodewidget)test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "(libksieveui-findbar-findbarbase|sieveeditorhelphtmlwidget|sieveeditor-autocreatescripts-sieveeditorgraphicalmodewidget)test"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-ed4a116e26e27606b54b83a4c48038b962b32f294cdfdfed87bc9dc280d660a6f3345312bee8a61a2e17c7fa2c896cabc6856991d6d364dad19969411840b819 libksieve-21.08.3.tar.xz
+e85a47e8f6673ff41d35a26000e9fa36efac478cd7fb0bae8b03d22692f742d50840606e5913e5717df19b9879a39906baf1ad56650f21b954e32b973371d9b7 libksieve-24.02.2.tar.xz
"