aboutsummaryrefslogtreecommitdiffstats
path: root/community/libksieve/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libksieve/APKBUILD')
-rw-r--r--community/libksieve/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/community/libksieve/APKBUILD b/community/libksieve/APKBUILD
index 7d11b74618c..094dd34eb6b 100644
--- a/community/libksieve/APKBUILD
+++ b/community/libksieve/APKBUILD
@@ -1,12 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libksieve
-pkgver=22.04.2
+pkgver=24.02.1
pkgrel=0
pkgdesc="KDE PIM library for managing sieves"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !riscv64"
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
license="GPL-2.0-only"
depends_dev="
@@ -24,31 +27,33 @@ depends_dev="
kwindowsystem-dev
libkdepim-dev
pimcommon-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
syntax-highlighting-dev
"
makedepends="$depends_dev
+ doxygen
extra-cmake-modules
+ graphviz
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libksieve-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/libksieve.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libksieve-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
check() {
- cd build
-
# libksieveui-findbar-findbarbasetest, sieveeditorhelphtmlwidgettest and sieveeditor-autocreatescripts-sieveeditorgraphicalmodewidgettest require OpenGL
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(libksieveui-findbar-findbarbase|sieveeditorhelphtmlwidget|sieveeditor-autocreatescripts-sieveeditorgraphicalmodewidget)test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "(libksieveui-findbar-findbarbase|sieveeditorhelphtmlwidget|sieveeditor-autocreatescripts-sieveeditorgraphicalmodewidget)test"
}
package() {
@@ -56,5 +61,5 @@ package() {
}
sha512sums="
-811a930ade6d25f26e7a0e0a5cff42605a560ac2c331fed05d757f7518fe2dd02096e5f251cf6f3673ce87209feeeb1c2216b408af1df14632ca7977e23236b5 libksieve-22.04.2.tar.xz
+bd09963fe872ea1f6b6565741c0f6ed0b1b89bf1faf952cbbb61a20a5cf9b93bd8b155323cb9d76bb1146df26d10a2f760d83458c7cd98901e2518134afe6906 libksieve-24.02.1.tar.xz
"