aboutsummaryrefslogtreecommitdiffstats
path: root/community/libktorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libktorrent/APKBUILD')
-rw-r--r--community/libktorrent/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/libktorrent/APKBUILD b/community/libktorrent/APKBUILD
index 2c52e312852..4f723c9f11f 100644
--- a/community/libktorrent/APKBUILD
+++ b/community/libktorrent/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libktorrent
-pkgver=21.08.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/internet/org.kde.ktorrent"
pkgdesc="A powerful BitTorrent client for KDE"
license="GPL-2.0-or-later"
@@ -17,31 +19,32 @@ depends_dev="
ki18n-dev
kio-dev
qca-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
solid-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libktorrent-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/network/libktorrent.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libktorrent-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
# utppolltest requires network access
# superseedtest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(utppoll|superseed)test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "(utppoll|superseed)test"
}
package() {
@@ -49,5 +52,5 @@ package() {
}
sha512sums="
-84d3e59b381d7bbb4515ae4bc989110adf955603a9dbf0970ad47311a4e0c3dc4f20e52752e1d3a33374e46353149da88507014fc096f5643691485b55db3781 libktorrent-21.08.2.tar.xz
+bda6c2a25cedc89b95a0aab4443a4609b02d4ba60088634a4d5cf07a613dba8e498755c60210859429949576ec0383d94521f3859abfe55698a55940b5b9b996 libktorrent-24.02.2.tar.xz
"