aboutsummaryrefslogtreecommitdiffstats
path: root/community/libktorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libktorrent/APKBUILD')
-rw-r--r--community/libktorrent/APKBUILD67
1 files changed, 37 insertions, 30 deletions
diff --git a/community/libktorrent/APKBUILD b/community/libktorrent/APKBUILD
index 2735dca8118..d518e435ec8 100644
--- a/community/libktorrent/APKBUILD
+++ b/community/libktorrent/APKBUILD
@@ -1,49 +1,56 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libktorrent
-pkgver=2.1.1
-_ktorrentver=5.1.2 # $_ktorrentver=ktorrent-$pkgver
-pkgrel=2
+pkgver=24.02.2
+pkgrel=1
# armhf blocked by extra-cmake-modules
-# mips test failures
-arch="all !armhf !mips !mips64"
+arch="all !armhf"
url="https://kde.org/applications/internet/org.kde.ktorrent"
pkgdesc="A powerful BitTorrent client for KDE"
license="GPL-2.0-or-later"
-depends_dev="qt5-qtbase-dev karchive-dev kcrash-dev ki18n-dev kio-dev solid-dev boost-dev gmp-dev qca-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen graphviz"
+depends_dev="
+ boost-dev
+ gmp-dev
+ karchive-dev
+ kcrash-dev
+ ki18n-dev
+ kio-dev
+ qca-dev
+ qt6-qtbase-dev
+ solid-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/ktorrent/$_ktorrentver/libktorrent-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
+subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/network/libktorrent.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libktorrent-$pkgver.tar.xz"
build() {
- cd "$builddir"/build
- cmake "$builddir" \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
- make docs
+ cmake --build build
}
check() {
- cd "$builddir"/build
- # utppolltest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "utppolltest"
+ # utppolltest requires network access
+ # superseedtest is broken
+ xvfb-run ctest --test-dir build --output-on-failure -E "(utppoll|superseed)test"
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
-
- mkdir -p "$pkgdir"/usr/share/doc
- mv apidocs/html "$pkgdir"/usr/share/doc/HTML
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="5c7f0218193cae148b03ae86a886b89d08a46200755728468ef271a6201add88eca617898d486d1823699def282d0251e26e3b28d2642f45cab966c286127d37 libktorrent-2.1.1.tar.xz"
+sha512sums="
+bda6c2a25cedc89b95a0aab4443a4609b02d4ba60088634a4d5cf07a613dba8e498755c60210859429949576ec0383d94521f3859abfe55698a55940b5b9b996 libktorrent-24.02.2.tar.xz
+"