aboutsummaryrefslogtreecommitdiffstats
path: root/community/libldac/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libldac/APKBUILD')
-rw-r--r--community/libldac/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/libldac/APKBUILD b/community/libldac/APKBUILD
index 68f36775711..17d33c0997b 100644
--- a/community/libldac/APKBUILD
+++ b/community/libldac/APKBUILD
@@ -2,19 +2,19 @@
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=libldac
pkgver=2.0.2.3
-pkgrel=0
+pkgrel=1
pkgdesc="Lossy audio codec for Bluetooth connections"
url="https://github.com/EHfive/ldacBT"
license="Apache-2.0"
-arch="all !s390x !mips64" # no support for big-endian
-makedepends="cmake"
+arch="all !s390x" # no support for big-endian
+makedepends="cmake samurai"
subpackages="$pkgname-dev"
source="https://github.com/EHfive/ldacBT/releases/download/v$pkgver/ldacBT-$pkgver.tar.gz"
builddir="$srcdir/ldacBT"
options="!check" # no test suite
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build