aboutsummaryrefslogtreecommitdiffstats
path: root/community/liblo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/liblo/APKBUILD')
-rw-r--r--community/liblo/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/liblo/APKBUILD b/community/liblo/APKBUILD
new file mode 100644
index 00000000000..b0d0f7e6cf2
--- /dev/null
+++ b/community/liblo/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=liblo
+pkgver=0.31
+pkgrel=1
+pkgdesc="Open Sound Control protocol implementation for POSIX systems"
+url="https://liblo.sourceforge.net/"
+arch="all"
+license="LGPL-2.1-or-later"
+subpackages="$pkgname-dev"
+source="https://downloads.sourceforge.net/liblo/liblo-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="97f9561296c2e53f92db0cfee625687208b490f8bc229b6cffe88b43ca2a8da1ed3217aaa2151245ea483e54ad6c5e92b9cf10a20661766fa6d3bedb5a8cdd01 liblo-0.31.tar.gz"