aboutsummaryrefslogtreecommitdiffstats
path: root/community/libltc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libltc/APKBUILD')
-rw-r--r--community/libltc/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/libltc/APKBUILD b/community/libltc/APKBUILD
new file mode 100644
index 00000000000..d1024878403
--- /dev/null
+++ b/community/libltc/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Magnus Sandin <magnus.sandin@gmail.com>
+# Maintainer: Magnus Sandin <magnus.sandin@gmail.com>
+pkgname=libltc
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="provides functionality to encode and decode LTC audio"
+url="https://github.com/x42/libltc"
+arch="all"
+license="LGPL-3.0-only"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/x42/libltc/releases/download/v$pkgver/libltc-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ ./configure --prefix="/usr" \
+ --build=$CBUILD \
+ --host=$CHOST
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ make -j 1 check
+}
+
+sha512sums="
+3b29b7da1ad9f85c62068b927abec9b3963a77558b46b3ee7681f360642570935becedcf95436574a8a7b456c7e0b414131571d71c6903139f9e7565968278a6 libltc-1.3.2.tar.gz
+"