aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmaa/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libmaa/APKBUILD')
-rw-r--r--community/libmaa/APKBUILD34
1 files changed, 16 insertions, 18 deletions
diff --git a/community/libmaa/APKBUILD b/community/libmaa/APKBUILD
index 02689b0ba19..832823a4bb2 100644
--- a/community/libmaa/APKBUILD
+++ b/community/libmaa/APKBUILD
@@ -1,31 +1,29 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
-# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: Ngô Ngọc Đức Huy <huyngo@disroot.org>
pkgname=libmaa
-pkgver=1.3.2
-pkgrel=1
+pkgver=1.4.7
+pkgrel=0
pkgdesc="Provides many low-level data structures which are helpful for writing compilers"
url="https://sourceforge.net/projects/dict/"
arch="all"
-license="GPL-1.0-or-later AND LGPL-2.0-or-later"
-makedepends="libtool perl flex"
-subpackages="$pkgname-dev"
-source="https://downloads.sourceforge.net/dict/libmaa-$pkgver.tar.gz
- fix-ppc64le-build-snprinf-buflen.patch"
-options="libtool"
+license="MIT"
+makedepends="mk-configure"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/dict/libmaa-$pkgver.tar.gz"
+options="!check" # flaky test
-prepare() {
- default_prepare
- update_config_guess
+build() {
+ mkcmake PREFIX=/usr
}
-build() {
- ./configure --prefix=/usr
- make
+check() {
+ mkcmake test PREFIX=/usr
}
package() {
- make DESTDIR="$pkgdir" install
+ mkcmake install PREFIX=/usr DESTDIR="$pkgdir"
}
-sha512sums="dde91e8bf1c08515ff4662282d16a03b18a1dfb16eb7b95be980ba398ed1e65d8cd88e58d454e03a03f48a5ecca8bf23b4ebaf475a98630a9178318c12a1b176 libmaa-1.3.2.tar.gz
-8efab0163bbdb0e16cc4914779cddccd53b6107c0ddc5b8c370e408f837d6ababd490e52e91386df7bc69d3a973a38f19e3721f379528b17913b5a32bfab6101 fix-ppc64le-build-snprinf-buflen.patch"
+sha512sums="
+6aa0ec6de92d9512152116a2698f5e7d3166631832968d2b7942b8564a4d61ef6eaf304d863e682758636e55a0c5d26fde49db028b18c160abb2286683e8478b libmaa-1.4.7.tar.gz
+"