aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmbim/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libmbim/APKBUILD')
-rw-r--r--community/libmbim/APKBUILD37
1 files changed, 19 insertions, 18 deletions
diff --git a/community/libmbim/APKBUILD b/community/libmbim/APKBUILD
index 31e57c09c89..2b11146195b 100644
--- a/community/libmbim/APKBUILD
+++ b/community/libmbim/APKBUILD
@@ -1,49 +1,50 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=libmbim
-pkgver=1.24.8
+pkgver=1.30.0
pkgrel=0
pkgdesc="MBIM modem protocol helper library"
url="https://www.freedesktop.org/wiki/Software/libmbim/"
arch="all"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
-makedepends="gtk-doc python3 glib-dev py3-gobject3 libgudev-dev
- gobject-introspection-dev"
+makedepends="
+ bash-completion-dev
+ glib-dev
+ gobject-introspection-dev
+ help2man
+ meson
+ py3-gobject3
+ python3
+ "
subpackages="
$pkgname-dev
$pkgname-doc
$pkgname-tools
$pkgname-bash-completion
"
-source="https://www.freedesktop.org/software/libmbim/libmbim-$pkgver.tar.xz"
+source="https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/archive/$pkgver/libmbim-$pkgver.tar.gz"
build() {
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-static \
- --enable-introspection=yes
- make
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
check() {
- make check
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
tools() {
pkgdesc="Tools for libmbim"
- mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/libexec
- mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/libexec/* "$subpkgdir"/usr/libexec
- rmdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/libexec 2>/dev/null || true
+ amove usr/bin usr/libexec
}
sha512sums="
-32a1ed379fb2799c8490058a16f819620290c2a08d0dacacdc7db4a31fb66a4d9c449b4b2d8fd6de898da28815a6c32e3d97a802970115ac2869e7fec0d841af libmbim-1.24.8.tar.xz
+5e2fa011e956ad4cccaf0cddc8d0acdaa8f789f6d37d8951fddb2cdb8d54ecc3cb6b89e247074604ce69fa9b28ea1da1cfd34ce9a001cd3fdd414ed134d132b6 libmbim-1.30.0.tar.gz
"