aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmicrohttpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libmicrohttpd/APKBUILD')
-rw-r--r--community/libmicrohttpd/APKBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/community/libmicrohttpd/APKBUILD b/community/libmicrohttpd/APKBUILD
index df87cd354d0..8c061b98f82 100644
--- a/community/libmicrohttpd/APKBUILD
+++ b/community/libmicrohttpd/APKBUILD
@@ -1,25 +1,22 @@
+# Contributor: Evgeny Grin (Karlson2k) <k2k@narod.ru>
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libmicrohttpd
-pkgver=0.9.70
+pkgver=0.9.77
pkgrel=0
-pkgdesc="A small C library that is supposed to make it easy to run an HTTP server as part of another application."
+pkgdesc="small C library that is supposed to make it easy to run an HTTP server as part of another application"
url="https://www.gnu.org/software/libmicrohttpd/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="autoconf automake curl-dev gettext-dev gnutls-dev libgcrypt-dev libtool"
+makedepends="gnutls-dev"
+checkdepends="curl-dev"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
source="https://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-$pkgver.tar.gz
- disable-test_options.patch
+ broken-test.patch
"
-prepare() {
- default_prepare
- autoreconf -fi
-}
-
build() {
./configure \
--build=$CBUILD \
@@ -28,6 +25,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
+ --disable-thread-names \
--enable-largefile \
--enable-curl \
--enable-https \
@@ -41,9 +39,9 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- install -Dm644 "$builddir"/src/include/platform.h \
- "$pkgdir"/usr/include/platform.h
}
-sha512sums="391293688d5ef51cf8d918294000384cb291f46bf767295af5a97123c06c75573d480a6c4b2486712b53636fe3e5dc1f8827ccf4335ac435ec85c3529733d8f5 libmicrohttpd-0.9.70.tar.gz
-7bbd8d2571f2bf7d06c956cc5e5decf154139baa1a716b43501b822b18a396b2cc97efd72118bc3dd5e20439611eb333730c436fe9f0a1ce2cf928066520e619 disable-test_options.patch"
+sha512sums="
+001025c023dd94c4a0cf017ed575e65a577b5ce595e7e450346bfb75def77eaa8a4cfbeffb9f4b912e34165c2cfca147c02c895e067a4f6c5a321a12035758a5 libmicrohttpd-0.9.77.tar.gz
+5e5d4331ed9123c1be1dcf77697836ff246c5b297f1bbc7ad051f6a5b0dc68a8d9de17c08fa1363e4783730331dce7286777f714c732046738e4a7520dc038da broken-test.patch
+"