aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmicrohttpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libmicrohttpd/APKBUILD')
-rw-r--r--community/libmicrohttpd/APKBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/community/libmicrohttpd/APKBUILD b/community/libmicrohttpd/APKBUILD
index 7daabc3ff99..8c061b98f82 100644
--- a/community/libmicrohttpd/APKBUILD
+++ b/community/libmicrohttpd/APKBUILD
@@ -1,25 +1,22 @@
+# Contributor: Evgeny Grin (Karlson2k) <k2k@narod.ru>
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libmicrohttpd
-pkgver=0.9.72
+pkgver=0.9.77
pkgrel=0
pkgdesc="small C library that is supposed to make it easy to run an HTTP server as part of another application"
url="https://www.gnu.org/software/libmicrohttpd/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="autoconf automake curl-dev gettext-dev gnutls-dev libgcrypt-dev libtool"
+makedepends="gnutls-dev"
+checkdepends="curl-dev"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
source="https://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-$pkgver.tar.gz
- disable-test_options.patch
+ broken-test.patch
"
-prepare() {
- default_prepare
- autoreconf -fi
-}
-
build() {
./configure \
--build=$CBUILD \
@@ -28,6 +25,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
+ --disable-thread-names \
--enable-largefile \
--enable-curl \
--enable-https \
@@ -41,9 +39,9 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- install -Dm644 "$builddir"/src/include/platform.h \
- "$pkgdir"/usr/include/platform.h
}
-sha512sums="9695e2fb08785e4b60342226ef3a0af22da4d80f127e7db9ec80ce844f70d0d781b30af207d58d8eb691b85a5fe4691cb9ecf887ca86f5e059a05259ae041316 libmicrohttpd-0.9.72.tar.gz
-c064757b8d0c88aaaa9104463bbcdabf1055e3c8054f98091699b39a094c50146e994c0fb24d6c619ea0ad559245560cd3460b6b9085f7d4249877e88ffb32e7 disable-test_options.patch"
+sha512sums="
+001025c023dd94c4a0cf017ed575e65a577b5ce595e7e450346bfb75def77eaa8a4cfbeffb9f4b912e34165c2cfca147c02c895e067a4f6c5a321a12035758a5 libmicrohttpd-0.9.77.tar.gz
+5e5d4331ed9123c1be1dcf77697836ff246c5b297f1bbc7ad051f6a5b0dc68a8d9de17c08fa1363e4783730331dce7286777f714c732046738e4a7520dc038da broken-test.patch
+"