aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmowgli/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libmowgli/APKBUILD')
-rw-r--r--community/libmowgli/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/libmowgli/APKBUILD b/community/libmowgli/APKBUILD
new file mode 100644
index 00000000000..33a593c40ed
--- /dev/null
+++ b/community/libmowgli/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libmowgli
+pkgver=2.1.3
+pkgrel=4
+pkgdesc="C library framework designed to reduce writing of boilerplate code"
+url="https://github.com/atheme/libmowgli-2"
+arch="all"
+options="!check" # No test suite.
+license="ISC"
+makedepends="openssl-dev"
+subpackages="$pkgname-dev"
+source="https://github.com/atheme/libmowgli-2/archive/v$pkgver/libmowgli-$pkgver.tar.gz
+ cacheline.patch"
+
+builddir="$srcdir"/$pkgname-2-$pkgver
+
+prepare() {
+ default_prepare
+ # workaround bug in busybox
+ sed -e "/touch/s/0001010000/200001010000/g" \
+ -i configure
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="bf976cf8b8bf0efaf7565230f42147adcdbe993339f58f907f5005eddf178d936cffb6cdbba59e38813854f30414856a1b9f8bdc972ea2f59cb08987ee336533 libmowgli-2.1.3.tar.gz
+861f043ef931b6d256c76c45a7958e3fdaf4db2d50ec09c2881a3d9f73c14666693cb11fc5a1ebbe1957efdaed970af86b7b61f2a02302d7f67d0f6c3e4f2bee cacheline.patch"