aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmpeg2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libmpeg2/APKBUILD')
-rw-r--r--community/libmpeg2/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/community/libmpeg2/APKBUILD b/community/libmpeg2/APKBUILD
new file mode 100644
index 00000000000..0c853031ce5
--- /dev/null
+++ b/community/libmpeg2/APKBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libmpeg2
+pkgver=0.5.1
+pkgrel=11
+pkgdesc="A library for decoding MPEG-1 and MPEG-2 video streams"
+url="https://libmpeg2.sourceforge.net/"
+arch="all"
+license="GPL-2.0"
+subpackages="$pkgname-dev $pkgname-doc mpeg2dec"
+makedepends="libx11-dev libice-dev libsm-dev libxext-dev libxv-dev"
+# Server changed directory structure
+# source="https://gentoo.osuosl.org/distfiles/libmpeg2-$pkgver.tar.gz
+source="https://distfiles.alpinelinux.org/distfiles/edge/libmpeg2-$pkgver.tar.gz
+ arm-private-symbols.patch
+ arm-textrel.patch
+ "
+
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-pic \
+ --enable-shared \
+ --disable-static
+ make OPT_CFLAGS="$CFLAGS" \
+ MPEG2DEC_CFLAGS="$CFLAGS" \
+ LIBMPEG2_CFLAGS=""
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+mpeg2dec() {
+ pkgdesc="a test program for libmpeg2"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/mpeg2dec "$subpkgdir"/usr/bin/
+}
+
+sha512sums="
+3648a2b3d7e2056d5adb328acd2fb983a1fa9a05ccb6f9388cc686c819445421811f42e8439418a0491a13080977f074a0d8bf8fa6bc101ff245ddea65a46fbc libmpeg2-0.5.1.tar.gz
+334e4e0b1e2877311503d2907f4f65c26d6a83ee79308c49697b2f3d2b8da9ac665e19ab419d85a944eaa34e1d43f512d1418a372cd444381d66f71df2a92c83 arm-private-symbols.patch
+888b8b4f90ece7f8dcd54895c36e2a93471de167f83cddc67d6943baf9e7ea19abd31ab055f6805629a2e176a1057e18de6a053fdea69cec90483a5165efa9c9 arm-textrel.patch
+"