aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmspub/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libmspub/APKBUILD')
-rw-r--r--community/libmspub/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/community/libmspub/APKBUILD b/community/libmspub/APKBUILD
index e73454d2937..d43497edb01 100644
--- a/community/libmspub/APKBUILD
+++ b/community/libmspub/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libmspub
pkgver=0.1.4
-pkgrel=3
+pkgrel=21
pkgdesc="Import filter and tools for MS Publisher files"
url="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
arch="all"
@@ -10,12 +10,18 @@ license="MPL-2.0"
depends_dev="boost-dev librevenge-dev zlib-dev icu-dev libwpd-dev libwpg-dev"
makedepends="$depends_dev doxygen"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
+source="https://dev-www.libreoffice.org/src/libmspub/libmspub-$pkgver.tar.xz
+ musl.patch
+ "
-builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare
+
+ update_config_guess
+ update_config_sub
+}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,7 +34,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -37,4 +42,5 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="7275f890645961b3fd56df4584788962e8c064fe3f99f5834c6ba6177ce76d00d544fbe9a25b7ab2f4180d2f3a90c609fe0bb68d61ea24e95b086190390fff31 libmspub-0.1.4.tar.xz"
+sha512sums="7275f890645961b3fd56df4584788962e8c064fe3f99f5834c6ba6177ce76d00d544fbe9a25b7ab2f4180d2f3a90c609fe0bb68d61ea24e95b086190390fff31 libmspub-0.1.4.tar.xz
+b3fe5c911b04e8fadab0dd0af8e60b05fc7ab80f727c0ea8675c9c1ebde316295a45ce38febfd38a17c5d766129202a7c4cb04fcc192a8034150d46602529d69 musl.patch"