aboutsummaryrefslogtreecommitdiffstats
path: root/community/libnice/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libnice/APKBUILD')
-rw-r--r--community/libnice/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/community/libnice/APKBUILD b/community/libnice/APKBUILD
index 6dabf7b4163..b065021c16f 100644
--- a/community/libnice/APKBUILD
+++ b/community/libnice/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libnice
-pkgver=0.1.18
-pkgrel=2
+pkgver=0.1.22
+pkgrel=0
pkgdesc="GLib ICE implementation"
options="!check" # Testsuite fails
url="https://libnice.freedesktop.org/"
@@ -14,7 +14,6 @@ makedepends="
gnutls-dev
gstreamer-dev
gobject-introspection-dev
- gtk-doc
meson"
subpackages="
$pkgname-dbg
@@ -24,9 +23,8 @@ source="https://nice.freedesktop.org/releases/libnice-$pkgver.tar.gz
libnice-meson-0.58.patch "
build() {
- # XXX: docs fail to build because of libnice not being built first,
- # race condition
abuild-meson \
+ -Db_lto=true \
-Dgtk_doc=disabled \
-Dtests=disabled \
-Dexamples=disabled \
@@ -34,7 +32,7 @@ build() {
-Dcrypto-library=gnutls \
-Dgstreamer=enabled \
-Dgupnp=disabled builddir
- meson compile ${JOBS:+-j ${JOBS}} -C builddir
+ meson compile -C builddir
}
package() {
@@ -43,11 +41,10 @@ package() {
_gst() {
pkgdesc="Gstreamer 1.0 plugin for libnice"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/gstreamer-1.0 "$subpkgdir"/usr/lib/
+ amove usr/lib/gstreamer-*
}
sha512sums="
-08bac05874708f7e7a669d28727d8951a10c464b22dd6fada1a4644850bcf5c4cc022cce46bb24c806086a7869b274c4c7d3d6ddaa9ed0ce0bc2c47f72933227 libnice-0.1.18.tar.gz
+c3aae2d36d2cec8654b87ecc464296711a4a64335052dfc1477f43f59e90341f7a6a01ebd4edf91a72d9ec425440e6dd0bd8f817c77e03578854e70193b3306b libnice-0.1.22.tar.gz
c59962a20d554da909a993f5d83d8d96da927d0ac94cfef2f699468326509f5715e8f7054badd25d07819b733dcea13c308b72aff170c013f7004dadba960dd7 libnice-meson-0.58.patch
"