aboutsummaryrefslogtreecommitdiffstats
path: root/community/libnitrokey/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libnitrokey/APKBUILD')
-rw-r--r--community/libnitrokey/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/libnitrokey/APKBUILD b/community/libnitrokey/APKBUILD
index a0c03f0dbe4..aaba13d0d04 100644
--- a/community/libnitrokey/APKBUILD
+++ b/community/libnitrokey/APKBUILD
@@ -1,27 +1,36 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libnitrokey
-pkgver=3.6
-pkgrel=0
+pkgver=3.8
+pkgrel=1
arch="all"
url="https://nitrokey.com/"
pkgdesc="Communicate with Nitrokey devices in a clean and easy manner"
license="LGPL-3.0-or-later"
-makedepends="cmake hidapi-dev"
+depends="nitrokey-udev-rules"
+makedepends="
+ cmake
+ hidapi-dev
+ "
source="https://github.com/Nitrokey/libnitrokey/archive/v$pkgver/libnitrokey-v$pkgver.tar.gz"
subpackages="$pkgname-dev"
options="!check" # No tests
build() {
- cmake \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
+
+ # The udev rules are shipping in the nitrokey-udev-rules dependency
+ rm -r "$pkgdir"/usr/lib/udev/rules.d
}
-sha512sums="a00a6724e5c64715eca688ec254efd979acceb5ff4cad28a205f7128e44db8674a5924634fd7da6c69d589deafca7b28b99e1d05a244c321d5cb429f2e5a3bec libnitrokey-v3.6.tar.gz"
+sha512sums="
+30f966eed77aa75057b096d18f8e88d6be28a376dfc1888e44aff80347e031a16755d30acf1bca196acc5b922778d90627ac71cba22f5cb002ba3ec058939c90 libnitrokey-v3.8.tar.gz
+"