aboutsummaryrefslogtreecommitdiffstats
path: root/community/libnotify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libnotify/APKBUILD')
-rw-r--r--community/libnotify/APKBUILD34
1 files changed, 24 insertions, 10 deletions
diff --git a/community/libnotify/APKBUILD b/community/libnotify/APKBUILD
index 318a04802f0..8bb0a869a79 100644
--- a/community/libnotify/APKBUILD
+++ b/community/libnotify/APKBUILD
@@ -1,32 +1,46 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libnotify
-pkgver=0.7.9
-pkgrel=2
+pkgver=0.8.3
+pkgrel=1
pkgdesc="Desktop notification library"
url="https://gitlab.gnome.org/GNOME/libnotify"
arch="all"
options="!check" # No tests defined when building with meson.
license="LGPL-2.1-or-later"
-makedepends="meson gdk-pixbuf-dev dbus-dev gtk+3.0-dev gobject-introspection-dev"
-subpackages="$pkgname-dev"
-source="https://download.gnome.org/sources/libnotify/${pkgver%.*}/libnotify-$pkgver.tar.xz"
+makedepends="
+ dbus-dev
+ docbook-xsl
+ gdk-pixbuf-dev
+ gobject-introspection-dev
+ gtk+3.0-dev
+ meson
+ "
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/libnotify/${pkgver%.*}/libnotify-$pkgver.tar.xz
+ docbook-url.patch
+ "
build() {
abuild-meson \
- -Dtests=true \
+ -Db_lto=true \
+ -Dtests="$(want_check && echo true || echo false)"\
-Dintrospection=enabled \
-Dgtk_doc=false \
- -Dman=false \
+ -Dman=true \
output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="8a842b50777279efdb7d96a836a546c47decad158a4f03f7ffc818860d1f6276a657619e4f4a19a4e2f5ad55e0371c793420d50d802983700e8c342273b73874 libnotify-0.7.9.tar.xz"
+
+sha512sums="
+e55073fdf418a4c04375825221edc92ab6a01201b83db2a1f1530f8f91f7da9da32327452b0785251790553517dcc717cfe623142450691b7dd247ec9164cffb libnotify-0.8.3.tar.xz
+0df7aeb5aa6688cc2272e5f1bb39f5ef2644d245c9d7bbbf54c0e1ecfe9621f08e6fc6f3489bafe5feff5452df00bd230bc457404390df242ee0a2a686005a5b docbook-url.patch
+"