aboutsummaryrefslogtreecommitdiffstats
path: root/community/libnumbertext/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libnumbertext/APKBUILD')
-rw-r--r--community/libnumbertext/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/community/libnumbertext/APKBUILD b/community/libnumbertext/APKBUILD
index 42d2d40b097..c9cd4ee3482 100644
--- a/community/libnumbertext/APKBUILD
+++ b/community/libnumbertext/APKBUILD
@@ -1,15 +1,21 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libnumbertext
-pkgver=1.0.7
-pkgrel=0
+pkgver=1.0.11
+pkgrel=1
pkgdesc="Number to number name and money text conversion library"
url="https://github.com/Numbertext/libnumbertext"
arch="all"
license="BSD-3-Clause"
+checkdepends="bash"
subpackages="$pkgname-dev"
source="https://github.com/Numbertext/libnumbertext/releases/download/$pkgver/libnumbertext-$pkgver.tar.xz"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
@@ -31,4 +37,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="7755c713dd9b9b75e486eac7ffbfb418c3bdfefd67ecb149f0e25a339410814bf73296f69a4e009a17f9f21292f0eeafa931aef60596cd3d932dab47278de8c2 libnumbertext-1.0.7.tar.xz"
+sha512sums="
+0c4d2b98d8cef46a2c51c4265f96ac2af6e58d3b8e63e7b6a40134e86d1dc7bec38e048abf227d1ebad7774ba8a6d68a1fac464739914b2d14786c309819c836 libnumbertext-1.0.11.tar.xz
+"