aboutsummaryrefslogtreecommitdiffstats
path: root/community/liboauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/liboauth/APKBUILD')
-rw-r--r--community/liboauth/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/liboauth/APKBUILD b/community/liboauth/APKBUILD
index b7a1a70f485..a1063b1a044 100644
--- a/community/liboauth/APKBUILD
+++ b/community/liboauth/APKBUILD
@@ -1,24 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=liboauth
pkgver=1.0.3
-pkgrel=3
+pkgrel=5
pkgdesc="OAuth library functions"
-url="http://liboauth.sourceforge.net/"
+url="https://liboauth.sourceforge.net/"
arch="all"
license="MIT"
-depends=""
makedepends="nss-dev curl-dev automake autoconf libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/x42/liboauth/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- cd "$builddir"
+ default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,12 +30,10 @@ build() {
}
check() {
- cd "$builddir"
- make check
+ make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}