aboutsummaryrefslogtreecommitdiffstats
path: root/community/libowfat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libowfat/APKBUILD')
-rw-r--r--community/libowfat/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/community/libowfat/APKBUILD b/community/libowfat/APKBUILD
index 14fb97deed6..48911232f54 100644
--- a/community/libowfat/APKBUILD
+++ b/community/libowfat/APKBUILD
@@ -1,19 +1,17 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net"
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libowfat
-pkgver=0.32
-pkgrel=1
+pkgver=0.33
+pkgrel=0
pkgdesc="Reimplementation of libdjbr"
url="http://www.fefe.de/libowfat/"
arch="all"
license="GPL-2.0-only"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.fefe.de/$pkgname/$pkgname-$pkgver.tar.xz
- libowfat-0.32-gcc10.patch
- "
+source="https://www.fefe.de/libowfat/libowfat-$pkgver.tar.xz"
build() {
- make CFLAGS="-I. ${CFLAGS}"
+ make CFLAGS="$CFLAGS -I$builddir" -j1
}
package() {
@@ -26,5 +24,6 @@ package() {
"$pkgdir"/usr/share/man/man3/owfatbuffer.3
}
-sha512sums="c762a1aa27dfb30e2f6da67d1ad16da03d301b2e3cce33c83b69103183a6689a494c8cf8d7d4e26ad5b22130e4e0560d5f3ef6f44b14d706f10e2300ce11ff3b libowfat-0.32.tar.xz
-ba3eef982f8345a96b2612bfbb8a97dc6477b21a58a35cda513ecdcd346b0cbf752574d565003f1d6887cda4467d8efc5777aa4d80fd50f731d35387028cda84 libowfat-0.32-gcc10.patch"
+sha512sums="
+03a56bcbc1a58e340c473d260877218a35841a6915a8369381d74463244cd754fc736006344814855c4d33598ad811d51b7fff4ba41c5e6d38d56297903dcaf5 libowfat-0.33.tar.xz
+"