aboutsummaryrefslogtreecommitdiffstats
path: root/community/libpagemaker/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libpagemaker/APKBUILD')
-rw-r--r--community/libpagemaker/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/community/libpagemaker/APKBUILD b/community/libpagemaker/APKBUILD
index 1578f87fe87..cbaf69e2b65 100644
--- a/community/libpagemaker/APKBUILD
+++ b/community/libpagemaker/APKBUILD
@@ -2,22 +2,24 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libpagemaker
pkgver=0.0.4
-pkgrel=1
+pkgrel=8
pkgdesc="Import filter and tools for PageMaker"
url="https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker"
arch="all"
license="MPL-2.0"
-depends=""
depends_dev="boost-dev librevenge-dev"
makedepends="$depends_dev doxygen"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+
+ update_config_sub
+ update_config_guess
+}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -31,13 +33,11 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
tools() {
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+ amove usr/bin
}
sha512sums="d9d9436622ae378da2a3c8e50a35b6133582a595c9ff0fe0e3b124fd0b83f1f12afdfc6a27d16b509ca9bab33067215d7300e505d4bf6b280be7e4bf46da6c64 libpagemaker-0.0.4.tar.xz"