aboutsummaryrefslogtreecommitdiffstats
path: root/community/libpanel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libpanel/APKBUILD')
-rw-r--r--community/libpanel/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/libpanel/APKBUILD b/community/libpanel/APKBUILD
new file mode 100644
index 00000000000..5d709273136
--- /dev/null
+++ b/community/libpanel/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
+pkgname=libpanel
+pkgver=1.6.0
+pkgrel=0
+pkgdesc="Dock/panel library for GTK 4"
+url="https://gitlab.gnome.org/GNOME/libpanel"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="
+ gobject-introspection-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ vala
+ "
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://gitlab.gnome.org/GNOME/libpanel/-/archive/$pkgver/libpanel-$pkgver.tar.gz"
+
+build() {
+ abuild-meson \
+ -Db_lto=true \
+ -Ddocs=disabled \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+e09efd98293ddfd6b707bf8ad9f5945a504949c30a09164d4894af8568fd26fe770268998662c1aecbbe85a1becff8bdc04d6d6f7fde4317c650ba5248702189 libpanel-1.6.0.tar.gz
+"