aboutsummaryrefslogtreecommitdiffstats
path: root/community/libpg_query/unbundle-vendor-deps.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/libpg_query/unbundle-vendor-deps.patch')
-rw-r--r--community/libpg_query/unbundle-vendor-deps.patch26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/libpg_query/unbundle-vendor-deps.patch b/community/libpg_query/unbundle-vendor-deps.patch
index 72b3f318823..ec28a218ca4 100644
--- a/community/libpg_query/unbundle-vendor-deps.patch
+++ b/community/libpg_query/unbundle-vendor-deps.patch
@@ -2,25 +2,27 @@ Link against system provided protobuf-c and xxhash libraries.
--- a/Makefile
+++ b/Makefile
-@@ -19,16 +19,18 @@
- SONAME = lib$(TARGET).so.$(SOVERSION)
- SOLIB = $(SONAME).$(LIB_VERSION_MINOR).$(LIB_VERSION_PATCH)
+@@ -30,10 +30,11 @@
+ SOFLAG = -soname
+ endif
-SRC_FILES := $(wildcard src/*.c src/postgres/*.c) vendor/protobuf-c/protobuf-c.c vendor/xxhash/xxhash.c protobuf/pg_query.pb-c.c
+SRC_FILES := $(wildcard src/*.c src/postgres/*.c) protobuf/pg_query.pb-c.c
- NOT_OBJ_FILES := src/pg_query_enum_defs.o src/pg_query_fingerprint_defs.o src/pg_query_fingerprint_conds.o src/pg_query_outfuncs_defs.o src/pg_query_outfuncs_conds.o src/pg_query_readfuncs_defs.o src/pg_query_readfuncs_conds.o src/postgres/guc-file.o src/postgres/scan.o src/pg_query_json_helper.o
- OBJ_FILES := $(filter-out $(NOT_OBJ_FILES), $(SRC_FILES:.c=.o))
-
--override CFLAGS += -g -I. -I./vendor -I./src/postgres/include -Wall -Wno-unused-function -Wno-unused-value -Wno-unused-variable -fno-strict-aliasing -fwrapv -fPIC
+ OBJ_FILES := $(SRC_FILES:.c=.o)
+LIBS = -lxxhash -lprotobuf-c
-+
-+override CFLAGS += -g -I. -I./src/postgres/include -Wall -Wno-unused-function -Wno-unused-value -Wno-unused-variable -fno-strict-aliasing -fwrapv -fPIC
- override PG_CONFIGURE_FLAGS += -q --without-readline --without-zlib
+-override CFLAGS += -g -I. -I./vendor -I./src/include -I./src/postgres/include -Wall -Wno-unused-function -Wno-unused-value -Wno-unused-variable -fno-strict-aliasing -fwrapv -fPIC
++override CFLAGS += -g -I. -I./src/include -I./src/postgres/include -Wall -Wno-unused-function -Wno-unused-value -Wno-unused-variable -fno-strict-aliasing -fwrapv -fPIC
+
+ ifeq ($(OS),Windows_NT)
+ override CFLAGS += -I./src/postgres/include/port/win32
+@@ -41,8 +42,8 @@
+
+ override PG_CONFIGURE_FLAGS += -q --without-readline --without-zlib --without-icu
--override TEST_CFLAGS += -I. -I./vendor -g
+-override TEST_CFLAGS += -g -I. -I./vendor -Wall
-override TEST_LDFLAGS += -pthread
-+override TEST_CFLAGS += -I. -g
++override TEST_CFLAGS += -g -I. -Wall
+override TEST_LDFLAGS += -pthread $(LIBS)
CFLAGS_OPT_LEVEL = -O3