aboutsummaryrefslogtreecommitdiffstats
path: root/community/libpg_query/verbose-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/libpg_query/verbose-build.patch')
-rw-r--r--community/libpg_query/verbose-build.patch11
1 files changed, 5 insertions, 6 deletions
diff --git a/community/libpg_query/verbose-build.patch b/community/libpg_query/verbose-build.patch
index 02c6db46866..7d9c01fd2fa 100644
--- a/community/libpg_query/verbose-build.patch
+++ b/community/libpg_query/verbose-build.patch
@@ -2,16 +2,15 @@ We want to see what's going on, what flags are begin passed to CC.
--- a/Makefile
+++ b/Makefile
-@@ -148,18 +148,16 @@
- cp $(PGDIR)/src/test/regress/sql/*.sql ./test/sql/postgres_regress/
+@@ -168,17 +168,17 @@
.c.o:
-- @$(ECHO) compiling $(<)
+ @$(ECHO) compiling $(<)
- @$(CC) $(CPPFLAGS) $(CFLAGS) -o $@ -c $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ -c $<
.cc.o:
-- @$(ECHO) compiling $(<)
+ @$(ECHO) compiling $(<)
- @$(CXX) $(CXXFLAGS) -o $@ -c $<
+ $(CXX) $(CXXFLAGS) -o $@ -c $<
@@ -20,8 +19,8 @@ We want to see what's going on, what flags are begin passed to CC.
+ $(AR) $@ $(OBJ_FILES)
$(SOLIB): $(OBJ_FILES) Makefile
-- @$(CC) $(CFLAGS) -shared -Wl,-soname,$(SONAME) $(LDFLAGS) -o $@ $(OBJ_FILES) $(LIBS)
-+ $(CC) $(CFLAGS) -shared -Wl,-soname,$(SONAME) $(LDFLAGS) -o $@ $(OBJ_FILES) $(LIBS)
+- @$(CC) $(CFLAGS) -shared -Wl,$(SOFLAG),$(SONAME) $(LDFLAGS) -o $@ $(OBJ_FILES) $(LIBS)
++ $(CC) $(CFLAGS) -shared -Wl,$(SOFLAG),$(SONAME) $(LDFLAGS) -o $@ $(OBJ_FILES) $(LIBS)
protobuf/pg_query.pb-c.c protobuf/pg_query.pb-c.h: protobuf/pg_query.proto
ifneq ($(shell which protoc-gen-c), )