aboutsummaryrefslogtreecommitdiffstats
path: root/community/libphonenumber/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libphonenumber/APKBUILD')
-rw-r--r--community/libphonenumber/APKBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/community/libphonenumber/APKBUILD b/community/libphonenumber/APKBUILD
index d9378dbae7d..8d5ec175320 100644
--- a/community/libphonenumber/APKBUILD
+++ b/community/libphonenumber/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Bhushan Shah <bshah@kde.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libphonenumber
-pkgver=8.12.34
-pkgrel=1
+pkgver=8.13.32
+pkgrel=0
pkgdesc="Library for parsing, formatting, and validating international phone numbers."
-url="https://github.com/googlei18n/libphonenumber"
+url="https://github.com/google/libphonenumber"
arch="all"
license="Apache-2.0"
depends_dev="
- boost-dev
+ abseil-cpp-dev
icu-dev
protobuf-dev
"
@@ -17,19 +17,22 @@ makedepends="$depends_dev
gtest-dev
ninja
"
-checkdepends="gtest"
-subpackages="$pkgname-static $pkgname-dev"
-source="https://github.com/googlei18n/libphonenumber/archive/v$pkgver/libphonenumber-v$pkgver.tar.gz
- cmake-duplicate-rule-definition.patch
+checkdepends="icu-data-full"
+subpackages="$pkgname-static libgeocoding $pkgname-dev"
+source="https://github.com/google/libphonenumber/archive/v$pkgver/libphonenumber-v$pkgver.tar.gz
+ system-abseil.patch
"
build() {
cd cpp
+ LDFLAGS="$LDFLAGS -Wl,--copy-dt-needed-entries" \
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DREGENERATE_METADATA=OFF
+ -DREGENERATE_METADATA=OFF \
+ -DUSE_BOOST=OFF \
+ -DUSE_STDMUTEX=ON
cmake --build build
}
@@ -43,7 +46,11 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
+libgeocoding() {
+ amove usr/lib/libgeocoding.so.*
+}
+
sha512sums="
-6388acc1c1ef28da02e2380366b373a62a52f116ef8bf35ab09089af56027f369ab210ef5bae84adf68f690bc48c36c272cd935ab0b7965479553805db875f2c libphonenumber-v8.12.34.tar.gz
-dc76f0649c401ec97a7449373b96247135c3b80cf1e5bb8afba005fed1055a74429d3c778b7519b609bdcfbb278be395ef83e0bd00228239b6f15d96b0d2df11 cmake-duplicate-rule-definition.patch
+91c8bba4750f4d2bc94b403e176a5ae5e40f8a9e4d6906b095eedb15c30671fcacd94df9c21e9ef0929ea21488f21f9e8011cf6386439ea556f5052a31f46fa9 libphonenumber-v8.13.32.tar.gz
+03c1eb32208a868bcacf92eb42b1f3f009bcc898fa6446594a3e79baadbef5fb53bbe829adfb7d0c8ebebdd37898c6686ff837320d258cd47ef5de7a6bf341bc system-abseil.patch
"