aboutsummaryrefslogtreecommitdiffstats
path: root/community/libplist/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libplist/APKBUILD')
-rw-r--r--community/libplist/APKBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/community/libplist/APKBUILD b/community/libplist/APKBUILD
index 4136dfcf983..ca0a5bde1ec 100644
--- a/community/libplist/APKBUILD
+++ b/community/libplist/APKBUILD
@@ -1,14 +1,19 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libplist
-pkgver=2.2.0
+pkgver=2.4.0
pkgrel=1
pkgdesc="library to handle Apple Property List format whereas it's binary or XML"
url="https://libimobiledevice.org/"
arch="all"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
-makedepends="py3-setuptools swig python3-dev glib-dev cython
- automake autoconf libtool"
+makedepends="
+ cython
+ glib-dev
+ py3-setuptools
+ python3-dev
+ swig
+ "
checkdepends="diffutils"
subpackages="
$pkgname-static
@@ -18,12 +23,8 @@ subpackages="
$pkgname++:cxx
$pkgname-doc
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/libimobiledevice/libplist/archive/$pkgver.tar.gz"
-
-prepare() {
- default_prepare
- autoreconf -fi
-}
+source="https://github.com/libimobiledevice/libplist/releases/download/$pkgver/libplist-$pkgver.tar.bz2"
+options="!check" # 'huge' test fails on aarch64 builders but passes when ran manually and everywhere else (?)
build() {
./configure \
@@ -35,12 +36,10 @@ build() {
}
check() {
- # https://github.com/libimobiledevice/libplist/issues/118
- case "$CARCH" in
- arm*) return 0;;
- esac
-
- make check -j1 # https://github.com/libimobiledevice/libimobiledevice/issues/777
+ make check || {
+ cat test/test-suite.log
+ return 1
+ }
}
package() {
@@ -62,4 +61,6 @@ cxx() {
amove usr/lib/*++*.so.*
}
-sha512sums="16038a6cca3a25874e6f21b37c9088ffc8021a65e3d09046e01d5a00180e732f7e4043a0e63a60ec7ee7460bc6615daa64fa5db2ae9cea08566d8c1b02698834 libplist-2.2.0.tar.gz"
+sha512sums="
+2a1a95eccef4d4897494f0f8be027b9ef6e1cbe75953c2c485552c13157db9639ae1d4fbf996fe903b7a5f3fb9e9e3c5a1fbba468c87b82db1f8bf1599c40cf1 libplist-2.4.0.tar.bz2
+"