aboutsummaryrefslogtreecommitdiffstats
path: root/community/libptytty/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libptytty/APKBUILD')
-rw-r--r--community/libptytty/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/libptytty/APKBUILD b/community/libptytty/APKBUILD
new file mode 100644
index 00000000000..d1959954f0e
--- /dev/null
+++ b/community/libptytty/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=libptytty
+pkgver=2.0
+pkgrel=0
+pkgdesc="OS independent pty/tty and utmp/wtmp/lastlog handling"
+url="http://software.schmorp.de/pkg/libptytty.html"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="cmake"
+options="!check" # no testsuite
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://dist.schmorp.de/libptytty/libptytty-$pkgver.tar.gz"
+
+build() {
+ # musl does not have UTMP/WTMP built-in support. We could depend
+ # on the utmps package for UTMP support but currently this
+ # package is only a dependency of rxvt-unicode and we previously
+ # build rxvt-unicode without UTMP support as well.
+ cmake -B build \
+ -DUTMP_SUPPORT=OFF \
+ -DWTMP_SUPPORT=OFF \
+ -DLASTLOG_SUPPORT=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=None \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+9cca5fddbcc4025c2bbe043e3367ac902d0024a34301258dafcf0de70935c055279d88227168d112d0e4c0dc37f1f49e1ea587bd6bddf0b9d92400657bc7be08 libptytty-2.0.tar.gz
+"