aboutsummaryrefslogtreecommitdiffstats
path: root/community/libqxp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libqxp/APKBUILD')
-rw-r--r--community/libqxp/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/libqxp/APKBUILD b/community/libqxp/APKBUILD
index 122e6a6af04..20224d078cc 100644
--- a/community/libqxp/APKBUILD
+++ b/community/libqxp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=libqxp
pkgver=0.0.2
-pkgrel=5
+pkgrel=10
pkgdesc="Library that parses the file format of QuarkXPress documents."
url="https://wiki.documentfoundation.org/DLP/Libraries/libqxp"
arch="all"
@@ -9,10 +9,13 @@ license="MPL-2.0"
makedepends="librevenge-dev icu-dev doxygen"
subpackages="$pkgname-dev $pkgname-doc"
source="https://dev-www.libreoffice.org/src/libqxp/libqxp-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ default_prepare
+ update_config_guess
+}
build() {
- cd "$builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -21,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}