aboutsummaryrefslogtreecommitdiffstats
path: root/community/libraw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libraw/APKBUILD')
-rw-r--r--community/libraw/APKBUILD35
1 files changed, 26 insertions, 9 deletions
diff --git a/community/libraw/APKBUILD b/community/libraw/APKBUILD
index b09b065f95a..b60ec66e30c 100644
--- a/community/libraw/APKBUILD
+++ b/community/libraw/APKBUILD
@@ -1,16 +1,31 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libraw
-pkgver=0.19.5
+pkgver=0.21.2
pkgrel=0
pkgdesc="Library for reading RAW files obtained from digital photo cameras"
-url="https://www.libraw.org"
+url="https://www.libraw.org/"
arch="all"
license="CDDL-1.0 OR LGPL-2.1-only"
+makedepends="lcms2-dev"
subpackages="$pkgname-dev $pkgname-tools"
source="https://www.libraw.org/data/LibRaw-$pkgver.tar.gz"
builddir="$srcdir"/LibRaw-$pkgver
+options="!check" # no tests
# secfixes:
+# 0.21.1-r2:
+# - CVE-2023-1729
+# 0.20.0-r0:
+# - CVE-2020-24890
+# - CVE-2020-24899
+# - CVE-2020-35530
+# - CVE-2020-35531
+# - CVE-2020-35532
+# - CVE-2020-35533
+# - CVE-2020-35534
+# - CVE-2020-35535
+# 0.19.5-r1:
+# - CVE-2020-15503
# 0.19.2-r0:
# - CVE-2018-20363
# - CVE-2018-20364
@@ -25,13 +40,15 @@ builddir="$srcdir"/LibRaw-$pkgver
# - CVE-2017-14265
build() {
- #export CXXFLAGS="$CXXFLAGS -std=gnu++98"
+ # trading size for more speed
+ CFLAGS="$CFLAGS -O3 -flto=auto" \
+ CXXFLAGS="$CXXFLAGS -O3 -flto=auto" \
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --disable-static
- #make lib/libraw.a lib/libraw_r.a
+ --disable-static \
+ --enable-openmp
make
}
@@ -42,9 +59,9 @@ package() {
tools() {
pkgdesc="tools for LibRaw"
-
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+ amove usr/bin
}
-sha512sums="4560045f75e6d2ab0d1d8686075f3a0e26a5d7ce693b48508110a2c31d19055d58983c24852da0abb64fa90db5e20f24b87aa7537ed04d958c38c8b265a7e826 LibRaw-0.19.5.tar.gz"
+sha512sums="
+ba7839d8eb5f999982c7b89f89f63387d7fee82054d7edcc2698924e268559b561230e329a0c669bd6f7c075983da6c054a6d63fad49ab3c1e2e9edc653b2bae LibRaw-0.21.2.tar.gz
+"