aboutsummaryrefslogtreecommitdiffstats
path: root/community/libressl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libressl/APKBUILD')
-rw-r--r--community/libressl/APKBUILD58
1 files changed, 36 insertions, 22 deletions
diff --git a/community/libressl/APKBUILD b/community/libressl/APKBUILD
index c58a9548c84..e2477ee647f 100644
--- a/community/libressl/APKBUILD
+++ b/community/libressl/APKBUILD
@@ -3,6 +3,8 @@
# Maintainer: Orion <systmkor@gmail.com>
#
# secfixes:
+# 3.4.3-r0:
+# - CVE-2022-0778
# 3.1.5-r0:
# - CVE-2020-1971
# 2.7.4-r0:
@@ -12,30 +14,29 @@
# - CVE-2017-8301
#
pkgname=libressl
-pkgver=3.4.2
+pkgver=3.8.2
_namever=${pkgname}${pkgver%.*}
pkgrel=0
pkgdesc="Version of the TLS/crypto stack forked from OpenSSL"
url="https://www.libressl.org/"
-arch="all"
+# s390x: does not build there anymore due to missing arch detection and arch code
+# even with asm disabled
+arch="all !s390x"
license="custom"
pcprefix="libressl:" # avoid mix up with openssl pkg-config
sonameprefix="libressl:" # avoid mix up with libretls
-makedepends_build="automake autoconf libtool"
+#makedepends_build="automake autoconf libtool"
makedepends_host="linux-headers"
makedepends="$makedepends_host $makedepends_build"
subpackages="$pkgname-dbg $_namever-libcrypto:_libs $_namever-libssl:_libs
- $_namever-libtls:_libs $pkgname-dev $pkgname-doc"
-source="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-$pkgver.tar.gz
- ssl-libcompat.patch
- disable-test.patch
- "
+ $_namever-libtls:_libs $pkgname-dev $pkgname-doc $pkgname-nc"
+source="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-$pkgver.tar.gz 0001-libressl.cnf.patch"
-prepare() {
- default_prepare
-
- autoreconf -vif
-}
+#prepare() {
+# default_prepare
+#
+# autoreconf -vif
+#}
build() {
CFLAGS="-L$CBUILDROOT/usr/lib $CFLAGS" \
@@ -46,7 +47,9 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --enable-nc \
+ --program-prefix "libressl-"
make
}
@@ -58,18 +61,30 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ # Remove symlinks that point to OpenSSL man pages.
+ # The symlink creation does not account for --program-prefix.
+ find -L "$pkgdir"/usr/share/man/man3/ -type l -delete
+
cd "$pkgdir"
- # /usr/bin/openssl is provided by the openssl package.
- mv usr/bin/openssl usr/bin/libressl
- mv usr/share/man/man1/openssl.1 usr/share/man/man1/libressl.1
+ # compatibility symlink (binary was called libressl previously).
+ ln -s libressl-ocspcheck "$pkgdir"/usr/bin/ocspcheck
+ ln -s libressl-ocspcheck.8 "$pkgdir"/usr/share/man/man8/ocspcheck.8
+ ln -s libressl-openssl "$pkgdir"/usr/bin/libressl
+ ln -s libressl-openssl.1 "$pkgdir"/usr/share/man/man1/libressl.1
# Provided by ca-certificates-cacerts
rm etc/ssl/cert.pem
rmdir etc/ssl/certs
- # Provided by openssl's libcrypto1.1
- rm etc/ssl/openssl.cnf
+ mv etc/ssl/openssl.cnf etc/ssl/libressl.cnf
+}
+
+nc() {
+ pkgdesc="libressl TLS-enabled nc(1)"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/libressl-nc "$subpkgdir"/usr/bin/nc
}
_libs() {
@@ -85,7 +100,6 @@ _libs() {
}
sha512sums="
-ae91a840b29330681dc2a4f55a9bd760e6fe1bdfb3399017aae3a16bd21b413e97cbb8ba504400f0a1f42757f6128b3fa763d06bae4fc9f2b9dbeea867a57ad2 libressl-3.4.2.tar.gz
-18e72b7db28664ee4e294a4a461e48daa90be9e9323584112a5878fd56a578d02f4730c7c788f57cc39b2bc35447df0a47a4391077d764d953419890ad511d35 ssl-libcompat.patch
-e786a19917900122c48b2e5882d357288b918f4ce07d697b4d9819f4c323020ae191a45dd7d5b75a3c20742d69ec89d72bf3a8d078b078c0e97f363db491ce6a disable-test.patch
+81765174fdd60223529182fab96249a28978c1d02b5894313d9b0b3aa365a1da2f7e5906403ab368114bdcba2fa861d1ad69b752f8344e6ea61d44666b483122 libressl-3.8.2.tar.gz
+aefa5dc99345462a93f97061fdee6b5b148eed30c4bf7a7097ade8cef9dd890d8d7100558d5e1ebe6790372261c76ce04a874526cb521dea068ec1439259a035 0001-libressl.cnf.patch
"