aboutsummaryrefslogtreecommitdiffstats
path: root/community/libretro-dosbox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libretro-dosbox/APKBUILD')
-rw-r--r--community/libretro-dosbox/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/libretro-dosbox/APKBUILD b/community/libretro-dosbox/APKBUILD
new file mode 100644
index 00000000000..693abc0af91
--- /dev/null
+++ b/community/libretro-dosbox/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-dosbox
+pkgver=0_git20220718
+pkgrel=0
+_commit="b7b24262c282c0caef2368c87323ff8c381b3102"
+pkgdesc="Port of DOSBox (upstream) to the libretro API"
+url="https://github.com/libretro/dosbox-libretro"
+arch="all"
+license="GPL-2.0-only"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/dosbox-libretro/archive/$_commit.tar.gz"
+builddir="$srcdir/dosbox-libretro-$_commit"
+options="!check" # No tests
+
+build() {
+ # force old c++ standard as the code is invalid c++17
+ CXXFLAGS="$CXXFLAGS -std=c++14" make -f Makefile.libretro
+}
+
+package() {
+ install -Dm644 dosbox_libretro.so "$pkgdir"/usr/lib/libretro/dosbox_libretro.so
+}
+
+sha512sums="
+b6f29addb06dd95a6aba4eed1b7ab9162f052c34273d3257d9676d3e12cda43a46ddae3dbeefa4e05de07cadc3441b0f7fbc49e5f14cfc35bc32d64386d95540 libretro-dosbox-b7b24262c282c0caef2368c87323ff8c381b3102.tar.gz
+"