aboutsummaryrefslogtreecommitdiffstats
path: root/community/libretro-dosbox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libretro-dosbox/APKBUILD')
-rw-r--r--community/libretro-dosbox/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/libretro-dosbox/APKBUILD b/community/libretro-dosbox/APKBUILD
index 57f466e0e3b..693abc0af91 100644
--- a/community/libretro-dosbox/APKBUILD
+++ b/community/libretro-dosbox/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: David Demelier <markand@malikania.fr>
# Maintainer: David Demelier <markand@malikania.fr>
pkgname=libretro-dosbox
-pkgver=0_git20201229
-pkgrel=1
-_commit="aa71b67d54eaaf9e41cdd3cb5153d9cff0ad116e"
+pkgver=0_git20220718
+pkgrel=0
+_commit="b7b24262c282c0caef2368c87323ff8c381b3102"
pkgdesc="Port of DOSBox (upstream) to the libretro API"
url="https://github.com/libretro/dosbox-libretro"
arch="all"
@@ -13,11 +13,14 @@ builddir="$srcdir/dosbox-libretro-$_commit"
options="!check" # No tests
build() {
- make -f Makefile.libretro
+ # force old c++ standard as the code is invalid c++17
+ CXXFLAGS="$CXXFLAGS -std=c++14" make -f Makefile.libretro
}
package() {
install -Dm644 dosbox_libretro.so "$pkgdir"/usr/lib/libretro/dosbox_libretro.so
}
-sha512sums="e2f1b7b8e5f35e2fa20c6ea3085fe9b96ca9a4d653019fb107def4859dab0928dfe6ec4f7c485dd9f8a3b29048b2b57604d98af352d61277541484ff83416ce8 libretro-dosbox-aa71b67d54eaaf9e41cdd3cb5153d9cff0ad116e.tar.gz"
+sha512sums="
+b6f29addb06dd95a6aba4eed1b7ab9162f052c34273d3257d9676d3e12cda43a46ddae3dbeefa4e05de07cadc3441b0f7fbc49e5f14cfc35bc32d64386d95540 libretro-dosbox-b7b24262c282c0caef2368c87323ff8c381b3102.tar.gz
+"