aboutsummaryrefslogtreecommitdiffstats
path: root/community/libretro-meteor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libretro-meteor/APKBUILD')
-rw-r--r--community/libretro-meteor/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/community/libretro-meteor/APKBUILD b/community/libretro-meteor/APKBUILD
new file mode 100644
index 00000000000..499bade6b67
--- /dev/null
+++ b/community/libretro-meteor/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-meteor
+pkgver=0_git20201228
+pkgrel=0
+_commit="e533d300d0561564451bde55a2b73119c768453c"
+pkgdesc="libretro port of Meteor GBA emulator"
+url="https://github.com/libretro/meteor-libretro"
+arch="all"
+license="GPL-3.0-only"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/meteor-libretro/archive/$_commit.tar.gz"
+builddir="$srcdir/meteor-libretro-$_commit"
+options="!check" # No tests
+
+build() {
+ make -C libretro
+}
+
+package() {
+ install -Dm644 libretro/meteor_libretro.so "$pkgdir"/usr/lib/libretro/meteor_libretro.so
+}
+
+sha512sums="7e73c404c06b0a04ef57a505ae2dbe41e88f877f2ef06ffbd9a5f35d8c19cc5bcf1d3338ac3a91cc281cd146a0bc27eb71e3246731fa1190081ad10e38c4fcb1 libretro-meteor-e533d300d0561564451bde55a2b73119c768453c.tar.gz"