aboutsummaryrefslogtreecommitdiffstats
path: root/community/libretro-prosystem/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libretro-prosystem/APKBUILD')
-rw-r--r--community/libretro-prosystem/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/libretro-prosystem/APKBUILD b/community/libretro-prosystem/APKBUILD
new file mode 100644
index 00000000000..5d4bfda2a2f
--- /dev/null
+++ b/community/libretro-prosystem/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-prosystem
+pkgver=0_git20230109
+pkgrel=0
+_commit="1924a37860b30dc9cef2a75a82c1cc470f9850b5"
+pkgdesc="port of ProSystem to the libretro API"
+url="https://github.com/libretro/prosystem-libretro"
+arch="all"
+license="GPL-2.0-only"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/prosystem-libretro/archive/$_commit.tar.gz"
+builddir="$srcdir/prosystem-libretro-$_commit"
+options="!check" # No tests
+
+build() {
+ make
+}
+
+package() {
+ install -Dm644 prosystem_libretro.so "$pkgdir"/usr/lib/libretro/prosystem_libretro.so
+}
+
+sha512sums="
+6f0de532479f2ad8e7a90e3f037b123e0fc559bffed51fdaf5b85a60f4105e8758e698a6d7a218cd3488cfe626fdbbee3c763cd801834e52204b5ffeff8cbafe libretro-prosystem-1924a37860b30dc9cef2a75a82c1cc470f9850b5.tar.gz
+"