aboutsummaryrefslogtreecommitdiffstats
path: root/community/librist/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/librist/APKBUILD')
-rw-r--r--community/librist/APKBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/community/librist/APKBUILD b/community/librist/APKBUILD
index 991dcf40969..f9bf4dde716 100644
--- a/community/librist/APKBUILD
+++ b/community/librist/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kevin Wang <kevin@muxable.com>
# Maintainer: Kevin Wang <kevin@muxable.com>
pkgname=librist
-pkgver=0.2.6
+pkgver=0.2.10
pkgrel=1
pkgdesc="Reliable Internet Stream Transport (RIST)"
url="https://www.rist.tv/"
@@ -10,23 +10,26 @@ license="BSD-2-Clause"
makedepends="meson linux-headers cjson-dev mbedtls-dev"
checkdepends="cmocka-dev"
subpackages="$pkgname-progs $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://code.videolan.org/rist/librist/-/archive/v$pkgver/librist-v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://code.videolan.org/rist/librist/-/archive/v$pkgver/librist-v$pkgver.tar.gz
+ fix-test.patch
+ "
builddir="$srcdir/librist-v$pkgver"
build() {
abuild-meson build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
- case "$CARCH" in
- ppc64le|arm*|s390x|aarch64)
- # tests fail
- ;;
- *)
- meson test --no-rebuild -v -C build
- ;;
- esac
+ # Tests are flaky & will fail if packets do not arrive in exact order.
+ # This often leads to having to retry the whole CI pipeline for s390x.
+ # Hopefully, repeating tests 3 times before failing will prevent that.
+ local i; for i in $(seq 0 3); do
+ [ $i -eq 0 ] || msg "Retrying ($i/3)..."
+ meson test --no-rebuild --print-errorlogs -C build && return 0
+ sleep 1
+ done
+ return 1
}
package() {
@@ -39,4 +42,7 @@ progs() {
amove usr/bin
}
-sha512sums="feef30219c6e6ad86229f7b069afb9f556e1f976a6b8a3e00473364808971da2155ea8a1bb2ff808f6218481f002910b8646f3194f2e9f272d110c15e64608a1 librist-0.2.6.tar.gz"
+sha512sums="
+cc0adda7c7bcde07904111e92a83716e76898f8b961870da56b8a6d947b7240cebd499a0874ddecd302f3aea45a9542380adfdb598ff859b2293b99f3b7fa578 librist-0.2.10.tar.gz
+8a1cbb5aa0233ff059ccef9d914673fb95ba6ff2184deddc509b24e0ae1c3f29941074bc2e96b174a5ab748f9f25b54debbdde59c136e0c3020d462a53410ce2 fix-test.patch
+"