aboutsummaryrefslogtreecommitdiffstats
path: root/community/librist/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/librist/APKBUILD')
-rw-r--r--community/librist/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/librist/APKBUILD b/community/librist/APKBUILD
index 8151a8f1352..f9bf4dde716 100644
--- a/community/librist/APKBUILD
+++ b/community/librist/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Kevin Wang <kevin@muxable.com>
# Maintainer: Kevin Wang <kevin@muxable.com>
pkgname=librist
-pkgver=0.2.7
-pkgrel=0
+pkgver=0.2.10
+pkgrel=1
pkgdesc="Reliable Internet Stream Transport (RIST)"
url="https://www.rist.tv/"
arch="all"
@@ -10,23 +10,26 @@ license="BSD-2-Clause"
makedepends="meson linux-headers cjson-dev mbedtls-dev"
checkdepends="cmocka-dev"
subpackages="$pkgname-progs $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://code.videolan.org/rist/librist/-/archive/v$pkgver/librist-v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://code.videolan.org/rist/librist/-/archive/v$pkgver/librist-v$pkgver.tar.gz
+ fix-test.patch
+ "
builddir="$srcdir/librist-v$pkgver"
build() {
abuild-meson build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
- case "$CARCH" in
- ppc64le|arm*|s390x|aarch64)
- # tests fail
- ;;
- *)
- meson test --no-rebuild -v -C build
- ;;
- esac
+ # Tests are flaky & will fail if packets do not arrive in exact order.
+ # This often leads to having to retry the whole CI pipeline for s390x.
+ # Hopefully, repeating tests 3 times before failing will prevent that.
+ local i; for i in $(seq 0 3); do
+ [ $i -eq 0 ] || msg "Retrying ($i/3)..."
+ meson test --no-rebuild --print-errorlogs -C build && return 0
+ sleep 1
+ done
+ return 1
}
package() {
@@ -40,5 +43,6 @@ progs() {
}
sha512sums="
-fa4e1aea75206781d062d350410e2f4e095e52191d22fb1882ec779ca13845294d00b5e4f06f04573eb8945ec280c304c96c1607622e978a241c5086b7d0a831 librist-0.2.7.tar.gz
+cc0adda7c7bcde07904111e92a83716e76898f8b961870da56b8a6d947b7240cebd499a0874ddecd302f3aea45a9542380adfdb598ff859b2293b99f3b7fa578 librist-0.2.10.tar.gz
+8a1cbb5aa0233ff059ccef9d914673fb95ba6ff2184deddc509b24e0ae1c3f29941074bc2e96b174a5ab748f9f25b54debbdde59c136e0c3020d462a53410ce2 fix-test.patch
"