aboutsummaryrefslogtreecommitdiffstats
path: root/community/librtas/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/librtas/APKBUILD')
-rw-r--r--community/librtas/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/community/librtas/APKBUILD b/community/librtas/APKBUILD
index 77fad080866..868dd3ca661 100644
--- a/community/librtas/APKBUILD
+++ b/community/librtas/APKBUILD
@@ -1,26 +1,23 @@
# Contributor: Breno Leitao <breno.leitao@gmail.com>
# Maintainer:
pkgname=librtas
-pkgver=2.0.2
-pkgrel=1
+pkgver=2.0.5
+pkgrel=0
pkgdesc="Librtas provides a set of libraries that access Run-Time Abstraction Services (RTAS)"
-url="https://github.com/nfont/librtas"
+url="https://github.com/ibm-power-utilities/librtas"
arch="ppc64le"
options="!check"
-license="LGPL"
+license="LGPL-2.1-or-later"
makedepends="autoconf automake libtool linux-headers"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/nfont/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ibm-power-utilities/librtas/archive/v$pkgver.tar.gz"
prepare() {
default_prepare
- cd "$builddir"
./autogen.sh
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,8 +26,9 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="112d355bc486657289a186d9f1b8c576af55422f1527259a0cd680c07d6fa787aef2dc0cb6322721dc4aa1c5bd1de669f5c4d05e6a07de65262e9e3d4d0283c7 librtas-2.0.2.tar.gz"
+sha512sums="
+afc4f3417321f68494439d837cbda9a32bef9ac67e7f2514687f6be1f38fe4719c33ce4eee01bfbd575f052677b0303dcc1d4b392bcbfa6f464299a3353bd9c4 librtas-2.0.5.tar.gz
+"