aboutsummaryrefslogtreecommitdiffstats
path: root/community/libselinux/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libselinux/APKBUILD')
-rw-r--r--community/libselinux/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/community/libselinux/APKBUILD b/community/libselinux/APKBUILD
index e073f51089f..ec6e4628619 100644
--- a/community/libselinux/APKBUILD
+++ b/community/libselinux/APKBUILD
@@ -1,21 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libselinux
-pkgver=3.3
-pkgrel=1
+pkgver=3.6
+pkgrel=0
pkgdesc="SELinux library and simple utilities"
url="https://github.com/SELinuxProject/selinux/wiki"
arch="all"
license="Public-Domain"
# we need coreutils for ln --relative
-makedepends="pcre-dev linux-headers libsepol-dev fts-dev coreutils"
+makedepends="pcre2-dev linux-headers libsepol-dev musl-fts-dev coreutils"
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
source="https://github.com/SELinuxProject/selinux/releases/download/$pkgver/libselinux-$pkgver.tar.gz
+ lfs64.patch
"
-if [ "$CARCH" = "riscv64" ]; then
- options="textrels"
-fi
-
build() {
make FTS_LDLIBS="-lfts"
}
@@ -26,10 +23,11 @@ package() {
utils() {
pkgdesc="SELinux libselinux utilies"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/
+
+ amove usr/sbin
}
sha512sums="
-9a89c05ea4b17453168a985ece93ba6d6c4127916e657c46d4135eb59a1f6408faa0802cc2e49187defbde5247d659037beee089877affbab3eab6af3433696c libselinux-3.3.tar.gz
+182dcdf3510083ff4b9376a4a6d6a7b33905ac3c5e974c188bf3965686c54b663162c543ecf15eab75102f3c91a2502d33d0f1104dec01dd9b14737ef3f2b544 libselinux-3.6.tar.gz
+a6098386275c67b5070cc62cd4f4d6ad5917182829e151b2d740ab71eec9e8c9835b633898537b62bf3811ac7e8a229de33bc650e8711e499256372ddec5e7fc lfs64.patch
"