aboutsummaryrefslogtreecommitdiffstats
path: root/community/libselinux/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libselinux/APKBUILD')
-rw-r--r--community/libselinux/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/libselinux/APKBUILD b/community/libselinux/APKBUILD
index d65a170e435..ec6e4628619 100644
--- a/community/libselinux/APKBUILD
+++ b/community/libselinux/APKBUILD
@@ -1,21 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libselinux
-pkgver=2.8
+pkgver=3.6
pkgrel=0
pkgdesc="SELinux library and simple utilities"
url="https://github.com/SELinuxProject/selinux/wiki"
arch="all"
license="Public-Domain"
# we need coreutils for ln --relative
-makedepends="pcre-dev linux-headers libsepol-dev fts-dev coreutils"
+makedepends="pcre2-dev linux-headers libsepol-dev musl-fts-dev coreutils"
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
-source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/libselinux-$pkgver.tar.gz
- musl.patch
+source="https://github.com/SELinuxProject/selinux/releases/download/$pkgver/libselinux-$pkgver.tar.gz
+ lfs64.patch
"
-
build() {
- make PCRE_LDLIBS="-lpcre -lfts"
+ make FTS_LDLIBS="-lfts"
}
package() {
@@ -24,9 +23,11 @@ package() {
utils() {
pkgdesc="SELinux libselinux utilies"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/
+
+ amove usr/sbin
}
-sha512sums="2f15d08888fbef9b0cf7bf01893b513edc6738974e2d0eab7e3f79cef9be79cf966742b0d2693b5d2ec7defddb5f4d6c6f6280be9d4158ed41f7a18d50b9f019 libselinux-2.8.tar.gz
-e5de8fb698222cdbec7a9a7af62419ed567d896a33caafc1b1c9c4741ae1e1d20be536b94a4b49393329b4a6526eb6435178aac689008ec665e12cbfe6eb332f musl.patch"
+sha512sums="
+182dcdf3510083ff4b9376a4a6d6a7b33905ac3c5e974c188bf3965686c54b663162c543ecf15eab75102f3c91a2502d33d0f1104dec01dd9b14737ef3f2b544 libselinux-3.6.tar.gz
+a6098386275c67b5070cc62cd4f4d6ad5917182829e151b2d740ab71eec9e8c9835b633898537b62bf3811ac7e8a229de33bc650e8711e499256372ddec5e7fc lfs64.patch
+"