aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsepol/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libsepol/APKBUILD')
-rw-r--r--community/libsepol/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/community/libsepol/APKBUILD b/community/libsepol/APKBUILD
index c82e216fff0..4c71bb0eb0f 100644
--- a/community/libsepol/APKBUILD
+++ b/community/libsepol/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libsepol
-pkgver=2.8
+pkgver=3.6
pkgrel=0
pkgdesc="SELinux binary policy manipulation library"
url="https://github.com/SELinuxProject/selinux/wiki"
@@ -10,25 +10,21 @@ depends_dev="bsd-compat-headers"
makedepends="$depends_dev flex-dev coreutils"
options="!check" # tests fail
subpackages="$pkgname-dev $pkgname-doc"
-source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/libsepol-$pkgver.tar.gz
+source="https://github.com/SELinuxProject/selinux/releases/download/$pkgver/libsepol-$pkgver.tar.gz
"
-builddir="$srcdir/libsepol-$pkgver"
build() {
- cd "$builddir"
- # More than a hundred multiple definitions
- CFLAGS="$CFLAGS -fcommon" \
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
check() {
- cd "$builddir"
make test
}
-sha512sums="dd065886819a265cd4f2751ac231a7baa5d7c7735844f3557d5c7e1feb06d4b4d03433d26ff6419b426caf90b69771ee743850fe45d36bc0201cadb86c62189c libsepol-2.8.tar.gz"
+sha512sums="
+35a42d2749fc4f71bc6b7488380714f56975564007128566f1c73e5c50bf81c17535b2cfda4583aacb4870aa2cd5885321c01523e415bda8b3326bfefb13d58e libsepol-3.6.tar.gz
+"