aboutsummaryrefslogtreecommitdiffstats
path: root/community/libshumate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libshumate/APKBUILD')
-rw-r--r--community/libshumate/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/libshumate/APKBUILD b/community/libshumate/APKBUILD
new file mode 100644
index 00000000000..9406fc78a08
--- /dev/null
+++ b/community/libshumate/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
+pkgname=libshumate
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="GTK4 widget to display maps"
+url="https://gitlab.gnome.org/GNOME/libshumate"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="
+ gobject-introspection-dev
+ gperf
+ gtk4.0-dev
+ json-glib-dev
+ libsoup3-dev
+ meson
+ protobuf-c-dev
+ vala
+ "
+checkdepends="dbus mesa-dri-gallium xvfb-run"
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://gitlab.gnome.org/GNOME/libshumate/-/archive/$pkgver/libshumate-$pkgver.tar.gz"
+options="!check"
+
+build() {
+ abuild-meson \
+ -Db_lto=true \
+ -Dgtk_doc=false \
+ -Dvector_renderer=true \
+ . output
+ meson compile -C output
+}
+
+check() {
+ dbus-run-session \
+ xvfb-run -a \
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+7a3ba38e9be05c806d8ba65f51bc739839b3845398b6bf73a8f841bb43652225b5053ba4bf66b0e7aa8edf48f8efc6867d6f5b6917bafae06868d6a68523f38e libshumate-1.2.0.tar.gz
+"